{"answers":{"affected":"3 open source packages ship an affected version, including authlib. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59420 exists.","fix":"Upgrade authlib to 1.6.4 or later.","what":"CVE-2025-59420 is a high-severity authentication bypass vulnerability in authlib, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59420 and fix it if it is affected.\n\nWhat it is: CVE-2025-59420 is a high-severity authentication bypass vulnerability in authlib, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59420 exists.\n\nAffected packages and fixed versions:\n- authlib (PyPI): affected all versions; fixed in 1.6.4\n- authlib (PyPI): affected all versions; fixed in 1.6.4\n- authlib (PyPI): affected all versions; fixed in 1.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59420/ (Markdown: https://insights.sbomify.com/CVE-2025-59420/index.md)","id":"CVE-2025-59420","markdown":"https://insights.sbomify.com/CVE-2025-59420/index.md","name":"CVE-2025-59420","record":{"aliases":["DEBIAN-CVE-2025-59420","ECHO-bedb-8942-b6fb","GHSA-9ggr-2464-2j32","PYSEC-2026-1200","ROOT-APP-PYPI-CVE-2025-59420","UBUNTU-CVE-2025-59420"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python OAuth library","requires_auth":"none","summary":"Attackers can bypass authentication or escalate privileges by crafting JWTs with unknown critical headers that Authlib incorrectly accepts.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"authlib","vendor":"authlib"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.4, Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. This issue has been patched in version 1.6.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)","id":"CVE-2025-59420","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Press vulnerable to email flooding to users due to lack of validation and rate limits","id":"CVE-2025-59421"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"authlib","purl":null,"source":"GHSA-9ggr-2464-2j32"},{"ecosystem":"PyPI","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"authlib","purl":"pkg:pypi/authlib","source":"GHSA-9ggr-2464-2j32"},{"ecosystem":"PyPI","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"authlib","purl":"pkg:pypi/authlib","source":"PYSEC-2026-1200"}],"prev":{"headline":"Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery","id":"CVE-2025-59419"},"products":["authlib"],"published":"2025-09-22","related":[{"cvss_score":9.1,"headline":"Authlib JWS JWK Header Injection: Signature Verification Bypass","id":"CVE-2026-27962","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":8.3,"headline":"Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle","id":"CVE-2026-28490","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":8.2,"headline":"Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding","id":"CVE-2026-28498","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":7.7,"headline":"Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification","id":"CVE-2026-28802","kev_date_added":null,"published":"2026-03-06"},{"cvss_score":7.5,"headline":"Authlib is vulnerable to Denial of Service via Oversized JOSE Segments","id":"CVE-2025-61920","kev_date_added":null,"published":"2025-10-10"},{"cvss_score":7.5,"headline":"Authlib has algorithm confusion with asymmetric public keys","id":"CVE-2024-37568","kev_date_added":null,"published":"2024-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["authlib"]},"summary":"Attackers can bypass authentication or escalate privileges by crafting JWTs with unknown critical headers that Authlib incorrectly accepts.","url":"https://insights.sbomify.com/CVE-2025-59420/"}