# CVE-2025-59420: Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)

> Attackers can bypass authentication or escalate privileges by crafting JWTs with unknown critical headers that Authlib incorrectly accepts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-59420, ECHO-bedb-8942-b6fb, GHSA-9ggr-2464-2j32, PYSEC-2026-1200, ROOT-APP-PYPI-CVE-2025-59420, UBUNTU-CVE-2025-59420

## What is CVE-2025-59420?

CVE-2025-59420 is a high-severity authentication bypass vulnerability in authlib, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.4, Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. This issue has been patched in version 1.6.4.

Weakness: CWE-863 (Incorrect Authorization), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2025-59420?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.4 |
| `authlib` | PyPI | All versions | 1.6.4 |
| `authlib` | PyPI | All versions | 1.6.4 |

Products: Authlib Authlib.

## How do I fix CVE-2025-59420?

Upgrade authlib to 1.6.4 or later.

## Is CVE-2025-59420 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59420 exists.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59420 and fix it if it is affected.

What it is: CVE-2025-59420 is a high-severity authentication bypass vulnerability in authlib, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59420 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.4
- authlib (PyPI): affected all versions; fixed in 1.6.4
- authlib (PyPI): affected all versions; fixed in 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59420/ (Markdown: https://insights.sbomify.com/CVE-2025-59420/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59420
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59420
- OSV: https://osv.dev/vulnerability/CVE-2025-59420

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59420/
Summaries are generated and may contain mistakes; the official description above is the record.
