# CVE-2025-59425: vLLM vulnerable to timing attack at bearer auth

> Attackers can bypass authentication in vLLM by exploiting a timing side-channel in API key validation to recover valid keys.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2025
- **Updated:** 7 Oct 2025
- **Also known as:** GHSA-wr9h-g72x-mwhm, PYSEC-2026-2026

## What is CVE-2025-59425?

CVE-2025-59425 is a high-severity authentication bypass vulnerability in Vllm Vllm, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Before version 0.11.0rc2, the API key support in vLLM performs validation using a method that was vulnerable to a timing attack. API key validation uses a string comparison that takes longer the more characters the provided API key gets correct. Data analysis across many attempts could allow an attacker to determine when it finds the next correct character in the key sequence. Deployments relying on vLLM's built-in API key validation are vulnerable to authentication bypass using this technique. Version 0.11.0rc2 fixes the issue.

Weakness: CWE-385 (Covert Timing Channel)

## Which versions are affected by CVE-2025-59425?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.11.0 |
| `vllm` | PyPI | All versions | 0.11.0 |
| `vllm` | PyPI | All versions | 0.11.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-59425?

Upgrade vllm to 0.11.0 or later.

## Is CVE-2025-59425 being exploited?

There is no known exploitation of CVE-2025-59425 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59425 and fix it if it is affected.

What it is: CVE-2025-59425 is a high-severity authentication bypass vulnerability in Vllm Vllm, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59425 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.11.0
- vllm (PyPI): affected all versions; fixed in 0.11.0
- vllm (PyPI): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59425/ (Markdown: https://insights.sbomify.com/CVE-2025-59425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59425
- OSV: https://osv.dev/vulnerability/CVE-2025-59425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59425/
Summaries are generated and may contain mistakes; the official description above is the record.
