{"answers":{"affected":"2 open source packages ship an affected version, including @cloudflare/vite-plugin.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59427 exists.","fix":"Upgrade @cloudflare/vite-plugin to 1.6.0 or later.","what":"CVE-2025-59427 is a low-severity vulnerability in cloudflare workers-sdk, published on 19 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59427 and fix it if it is affected.\n\nWhat it is: CVE-2025-59427 is a low-severity vulnerability in cloudflare workers-sdk, published on 19 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59427 exists.\n\nAffected packages and fixed versions:\n- @cloudflare/vite-plugin (npm): affected all versions; fixed in 1.6.0\n- @cloudflare/vite-plugin (npm): affected all versions; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59427/ (Markdown: https://insights.sbomify.com/CVE-2025-59427/index.md)","id":"CVE-2025-59427","markdown":"https://insights.sbomify.com/CVE-2025-59427/index.md","name":"CVE-2025-59427","record":{"aliases":["GHSA-4pfg-2mw5-f8jx"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudflare Vite plugin","requires_auth":"none","summary":"The Cloudflare Vite plugin exposes sensitive files like .env and .dev.vars via the local dev server, allowing attackers to read secrets.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Cloudflare Vite plugin enables a full-featured integration between Vite and the Workers runtime. When utilising the Cloudflare Vite plugin in its default configuration, all files are exposed by the local dev server, including files in the root directory that contain secret information such as .env and .dev.vars. This vulnerability is fixed in 1.6.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cloudflare vite plugin exposes secrets over the built-in dev server","id":"CVE-2025-59427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"EspoCRM allows arbitrary user creation via stored SVG injection and CSRF","id":"CVE-2025-59428"},"packages":[{"ecosystem":"npm","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"@cloudflare/vite-plugin","purl":null,"source":"GHSA-4pfg-2mw5-f8jx"},{"ecosystem":"npm","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"@cloudflare/vite-plugin","purl":"pkg:npm/%40cloudflare/vite-plugin","source":"GHSA-4pfg-2mw5-f8jx"}],"prev":{"headline":"lobe-chat has an Open Redirect","id":"CVE-2025-59426"},"products":["workers-sdk"],"published":"2025-09-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-19","vendors":["cloudflare"]},"summary":"The Cloudflare Vite plugin exposes sensitive files like .env and .dev.vars via the local dev server, allowing attackers to read secrets.","url":"https://insights.sbomify.com/CVE-2025-59427/"}