# CVE-2025-59427: Cloudflare vite plugin exposes secrets over the built-in dev server

> The Cloudflare Vite plugin exposes sensitive files like .env and .dev.vars via the local dev server, allowing attackers to read secrets.

- **Severity:** Low 2.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2025
- **Updated:** 19 Sep 2025
- **Also known as:** GHSA-4pfg-2mw5-f8jx

## What is CVE-2025-59427?

CVE-2025-59427 is a low-severity vulnerability in cloudflare workers-sdk, published on 19 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Cloudflare Vite plugin enables a full-featured integration between Vite and the Workers runtime. When utilising the Cloudflare Vite plugin in its default configuration, all files are exposed by the local dev server, including files in the root directory that contain secret information such as .env and .dev.vars. This vulnerability is fixed in 1.6.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-59427?

2 open source packages ship an affected version, including @cloudflare/vite-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cloudflare/vite-plugin` | npm | All versions | 1.6.0 |
| `@cloudflare/vite-plugin` | npm | All versions | 1.6.0 |

## How do I fix CVE-2025-59427?

Upgrade @cloudflare/vite-plugin to 1.6.0 or later.

## Is CVE-2025-59427 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59427 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59427 and fix it if it is affected.

What it is: CVE-2025-59427 is a low-severity vulnerability in cloudflare workers-sdk, published on 19 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59427 exists.

Affected packages and fixed versions:
- @cloudflare/vite-plugin (npm): affected all versions; fixed in 1.6.0
- @cloudflare/vite-plugin (npm): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59427/ (Markdown: https://insights.sbomify.com/CVE-2025-59427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59427
- OSV: https://osv.dev/vulnerability/CVE-2025-59427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59427/
Summaries are generated and may contain mistakes; the official description above is the record.
