# CVE-2025-59429: FreePBX core module vulnerable to reflected cross-site scripting via Asterisk HTTP Status page

> Unauthenticated attackers can exploit reflected XSS to steal admin cookies and hijack sessions, gaining control over the FreePBX interface.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Oct 2025
- **Updated:** 13 Feb 2026
- **Also known as:** GHSA-c8g7-475j-fwcc

## What is CVE-2025-59429?

CVE-2025-59429 is a high-severity cross-site scripting vulnerability in Sangoma Freepbx, published on 14 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

FreePBX is an open source GUI for managing Asterisk. In versions prior to 16.0.68.39 for FreePBX 16 and versions prior to 17.0.18.38 for FreePBX 17, a reflected cross-site scripting vulnerability is present on the Asterisk HTTP Status page. The Asterisk HTTP status page is exposed by FreePBX and is available by default on version 16 via any bound IP address at port 8088. By default on version 17, the binding is only to localhost IP, making it significantly less vulnerable. The vulnerability can be exploited by unauthenticated attackers to obtain cookies from logged-in users, allowing them to hijack a session of an administrative user. The theft of admin session cookies allows attackers to gain control over the FreePBX admin interface, enabling them to access sensitive data, modify system configurations, create backdoor accounts, and cause service disruption. This issue has been patched in version 16.0.68.39 for FreePBX 16 and version 17.0.18.38 for FreePBX 17.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59429?

It affects 1 product.


Products: Sangoma Freepbx.

## How do I fix CVE-2025-59429?

No fix has been published for CVE-2025-59429 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59429 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59429 exists.

## Other vulnerabilities in Sangoma Freepbx

- [CVE-2025-57819](https://insights.sbomify.com/CVE-2025-57819/): Sangoma FreePBX Authentication Bypass (critical 10.0, exploited in the wild)
- [CVE-2019-19006](https://insights.sbomify.com/CVE-2019-19006/): Sangoma FreePBX Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2026-73663](https://insights.sbomify.com/CVE-2026-73663/): FreePBX: Unauthenticated SQL injection in FreePBX missedcall via inbound Caller ID name leads to administrator takeover (critical 9.3)
- [CVE-2026-73665](https://insights.sbomify.com/CVE-2026-73665/): FreePBX UCP: Unauthenticated remote code execution via socket.io namespace auth bypass and AMI action injection (critical 9.3)
- [CVE-2026-46376](https://insights.sbomify.com/CVE-2026-46376/): FreePBX: Unauthenticated Use of Hard-Coded Credentials Vulnerability in FreePBX UCP Interface (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59429 and fix it if it is affected.

What it is: CVE-2025-59429 is a high-severity cross-site scripting vulnerability in Sangoma Freepbx, published on 14 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59429 exists.

Affected product: Sangoma Freepbx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59429/ (Markdown: https://insights.sbomify.com/CVE-2025-59429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59429
- OSV: https://osv.dev/vulnerability/CVE-2025-59429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59429/
Summaries are generated and may contain mistakes; the official description above is the record.
