# CVE-2025-59430: Mesh Connect JS SDK Vulnerable to Cross Site Scripting via createLink.openLink

> Attackers can execute arbitrary JavaScript in the parent page context via unsanitized URLs in the Mesh Connect JS SDK, accessing sensitive data.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-vh3f-qppr-j97f

## What is CVE-2025-59430?

CVE-2025-59430 is a high-severity cross-site scripting vulnerability in FrontFin mesh-web-sdk, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mesh Connect JS SDK contains JS libraries for integrating with Mesh Connect. Prior to version 3.3.2, the lack of sanitization of URLs protocols in the createLink.openLink function enables the execution of arbitrary JavaScript code within the context of the parent page. This is technically indistinguishable from a real page at the rendering level and allows access to the parent page DOM, storage, session, and cookies. If the attacker can specify customIframeId, they can hijack the source of existing iframes. This issue has been patched in version 3.3.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59430?

2 open source packages ship an affected version, including @meshconnect/web-link-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@meshconnect/web-link-sdk` | npm | All versions | 3.3.2 |
| `@meshconnect/web-link-sdk` | npm | All versions | 3.3.2 |

## How do I fix CVE-2025-59430?

Upgrade @meshconnect/web-link-sdk to 3.3.2 or later.

## Is CVE-2025-59430 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59430 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59430 and fix it if it is affected.

What it is: CVE-2025-59430 is a high-severity cross-site scripting vulnerability in FrontFin mesh-web-sdk, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59430 exists.

Affected packages and fixed versions:
- @meshconnect/web-link-sdk (npm): affected all versions; fixed in 3.3.2
- @meshconnect/web-link-sdk (npm): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59430/ (Markdown: https://insights.sbomify.com/CVE-2025-59430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59430
- OSV: https://osv.dev/vulnerability/CVE-2025-59430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59430/
Summaries are generated and may contain mistakes; the official description above is the record.
