CVE-2025-59432 Timing Attack Vulnerability in SCRAM Authentication
A timing side-channel in the SCRAM Java library allows attackers to infer authentication secrets via variable execution time in comparisons.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-59432?
CVE-2025-59432 is a medium-severity vulnerability in ongres scram, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
SCRAM (Salted Challenge Response Authentication Mechanism) is part of the family of Simple Authentication and Security Layer (SASL, RFC 4422) authentication mechanisms. Prior to version 3.2, a timing attack vulnerability exists in the SCRAM Java implementation. The issue arises because Arrays.equals was used to compare secret values such as client proofs and server signatures. Since Arrays.equals performs a short-circuit comparison, the execution time varies depending on how many leading bytes match. This behavior could allow an attacker to perform a timing side-channel attack and potentially infer sensitive authentication material. All users relying on SCRAM authentication are impacted. This vulnerability has been patched in version 3.1 by replacing Arrays.equals with MessageDigest.isEqual, which ensures constant-time comparison.
Which versions are affected by CVE-2025-59432?
2 open source packages ship an affected version, including com.ongres.scram:scram-common.
| Package | Affected | Fixed in |
|---|---|---|
com.ongres.scram:scram-common Maven | All versions | 3.2 |
com.ongres.scram:scram-common Maven | All versions | 3.2 |
Linux distribution packages (7)
ongres-scram SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 2.1-150400.8.5.1 |
ongres-scram SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 2.1-150400.8.5.1 |
ongres-scram SUSE:Linux Enterprise Server 16.0 | All versions | 3.1-160000.3.1 |
ongres-scram SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 3.1-160000.3.1 |
ongres-scram openSUSE:Leap 15.6 | All versions | 2.1-150400.8.5.1 |
ongres-scram openSUSE:Leap 16.0 | All versions | 3.1-160000.3.1 |
ongres-scram openSUSE:Tumbleweed | All versions | 3.2-7.1 |
How do I fix CVE-2025-59432?
Upgrade com.ongres.scram:scram-common to 3.2 or later.
Is CVE-2025-59432 being exploited?
There is no known exploitation of CVE-2025-59432 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2025-59432, GHSA-3wfh-36rx-9537, OESA-2025-2391, OESA-2025-2392, OESA-2025-2393, OESA-2025-2394 and 9 more.