# CVE-2025-59432: Timing Attack Vulnerability in SCRAM Authentication

> A timing side-channel in the SCRAM Java library allows attackers to infer authentication secrets via variable execution time in comparisons.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 23 Jan 2026
- **Also known as:** DEBIAN-CVE-2025-59432, GHSA-3wfh-36rx-9537, OESA-2025-2391, OESA-2025-2392, OESA-2025-2393, OESA-2025-2394, OESA-2025-2395, OESA-2025-2396, SUSE-SU-2025:21016-1, SUSE-SU-2025:4054-1, SUSE-SU-2026:21608-1, UBUNTU-CVE-2025-59432, openSUSE-SU-2025:15680-1, openSUSE-SU-2025:20059-1, openSUSE-SU-2026:20742-1

## What is CVE-2025-59432?

CVE-2025-59432 is a medium-severity vulnerability in ongres scram, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SCRAM (Salted Challenge Response Authentication Mechanism) is part of the family of Simple Authentication and Security Layer (SASL, RFC 4422) authentication mechanisms. Prior to version 3.2, a timing attack vulnerability exists in the SCRAM Java implementation. The issue arises because Arrays.equals was used to compare secret values such as client proofs and server signatures. Since Arrays.equals performs a short-circuit comparison, the execution time varies depending on how many leading bytes match. This behavior could allow an attacker to perform a timing side-channel attack and potentially infer sensitive authentication material. All users relying on SCRAM authentication are impacted. This vulnerability has been patched in version 3.1 by replacing Arrays.equals with MessageDigest.isEqual, which ensures constant-time comparison.

Weakness: CWE-385 (Covert Timing Channel), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2025-59432?

2 open source packages ship an affected version, including com.ongres.scram:scram-common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.ongres.scram:scram-common` | Maven | All versions | 3.2 |
| `com.ongres.scram:scram-common` | Maven | All versions | 3.2 |
| `ongres-scram` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 2.1-150400.8.5.1 |
| `ongres-scram` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 2.1-150400.8.5.1 |
| `ongres-scram` | SUSE:Linux Enterprise Server 16.0 | All versions | 3.1-160000.3.1 |
| `ongres-scram` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 3.1-160000.3.1 |
| `ongres-scram` | openSUSE:Leap 15.6 | All versions | 2.1-150400.8.5.1 |
| `ongres-scram` | openSUSE:Leap 16.0 | All versions | 3.1-160000.3.1 |
| `ongres-scram` | openSUSE:Tumbleweed | All versions | 3.2-7.1 |

## How do I fix CVE-2025-59432?

Upgrade com.ongres.scram:scram-common to 3.2 or later.

## Is CVE-2025-59432 being exploited?

There is no known exploitation of CVE-2025-59432 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59432 and fix it if it is affected.

What it is: CVE-2025-59432 is a medium-severity vulnerability in ongres scram, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59432 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.ongres.scram:scram-common (Maven): affected all versions; fixed in 3.2
- com.ongres.scram:scram-common (Maven): affected all versions; fixed in 3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59432/ (Markdown: https://insights.sbomify.com/CVE-2025-59432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59432
- OSV: https://osv.dev/vulnerability/CVE-2025-59432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59432/
Summaries are generated and may contain mistakes; the official description above is the record.
