{"answers":{"affected":"2 open source packages ship an affected version, including @conventional-changelog/git-client.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59433 exists.","fix":"Upgrade @conventional-changelog/git-client to 2.0.0 or later.","what":"CVE-2025-59433 is a medium-severity command injection vulnerability in conventional-changelog, published on 22 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59433 and fix it if it is affected.\n\nWhat it is: CVE-2025-59433 is a medium-severity command injection vulnerability in conventional-changelog, published on 22 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59433 exists.\n\nAffected packages and fixed versions:\n- @conventional-changelog/git-client (npm): affected all versions; fixed in 2.0.0\n- @conventional-changelog/git-client (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59433/ (Markdown: https://insights.sbomify.com/CVE-2025-59433/index.md)","id":"CVE-2025-59433","markdown":"https://insights.sbomify.com/CVE-2025-59433/index.md","name":"CVE-2025-59433","record":{"aliases":["GHSA-vh25-5764-9wcr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"npm changelog library","requires_auth":"high_privilege","summary":"Attackers can inject arguments into git commands via the getTags API, potentially overwriting arbitrary files using the --output option.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"Conventional Changelog generates changelogs and release notes from a project's commit messages and metadata. Prior to version 2.0.0, @conventional-changelog/git-client has an argument injection vulnerability. This vulnerability manifests with the library's getTags() API, which allows extra parameters to be passed to the git log command. In another API by this library, getRawCommits(), there are secure practices taken to ensure that the extra parameter path is unable to inject an argument by ending the git log command with the special shell syntax --. However, the library does not follow the same practice for getTags() as it does not attempt to sanitize for user input, validate the given params, or restrict them to an allow list. Nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options. Thus, allowing users to exploit an argument injection vulnerability in Git due to the --output= command-line option that results with overwriting arbitrary files. This issue has been patched in version 2.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@conventional-changelog/git-client has an Argument Injection vulnerability","id":"CVE-2025-59433","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Critical Multi-Tenant Variable Disclosure in Flowise Cloud via Custom JavaScript Function","id":"CVE-2025-59434"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"@conventional-changelog/git-client","purl":null,"source":"GHSA-vh25-5764-9wcr"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"@conventional-changelog/git-client","purl":"pkg:npm/%40conventional-changelog/git-client","source":"GHSA-vh25-5764-9wcr"}],"prev":{"headline":"Timing Attack Vulnerability in SCRAM Authentication","id":"CVE-2025-59432"},"products":["conventional-changelog"],"published":"2025-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-22","vendors":["conventional-changelog"]},"summary":"Attackers can inject arguments into git commands via the getTags API, potentially overwriting arbitrary files using the --output option.","url":"https://insights.sbomify.com/CVE-2025-59433/"}