# CVE-2025-59433: @conventional-changelog/git-client has an Argument Injection vulnerability

> Attackers can inject arguments into git commands via the getTags API, potentially overwriting arbitrary files using the --output option.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-vh25-5764-9wcr

## What is CVE-2025-59433?

CVE-2025-59433 is a medium-severity command injection vulnerability in conventional-changelog, published on 22 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Conventional Changelog generates changelogs and release notes from a project's commit messages and metadata. Prior to version 2.0.0, @conventional-changelog/git-client has an argument injection vulnerability. This vulnerability manifests with the library's getTags() API, which allows extra parameters to be passed to the git log command. In another API by this library, getRawCommits(), there are secure practices taken to ensure that the extra parameter path is unable to inject an argument by ending the git log command with the special shell syntax --. However, the library does not follow the same practice for getTags() as it does not attempt to sanitize for user input, validate the given params, or restrict them to an allow list. Nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options. Thus, allowing users to exploit an argument injection vulnerability in Git due to the --output= command-line option that results with overwriting arbitrary files. This issue has been patched in version 2.0.0.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2025-59433?

2 open source packages ship an affected version, including @conventional-changelog/git-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@conventional-changelog/git-client` | npm | All versions | 2.0.0 |
| `@conventional-changelog/git-client` | npm | All versions | 2.0.0 |

## How do I fix CVE-2025-59433?

Upgrade @conventional-changelog/git-client to 2.0.0 or later.

## Is CVE-2025-59433 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59433 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59433 and fix it if it is affected.

What it is: CVE-2025-59433 is a medium-severity command injection vulnerability in conventional-changelog, published on 22 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59433 exists.

Affected packages and fixed versions:
- @conventional-changelog/git-client (npm): affected all versions; fixed in 2.0.0
- @conventional-changelog/git-client (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59433/ (Markdown: https://insights.sbomify.com/CVE-2025-59433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59433
- OSV: https://osv.dev/vulnerability/CVE-2025-59433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59433/
Summaries are generated and may contain mistakes; the official description above is the record.
