{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59464 in the wild and no public exploit code.","fix":"Upgrade node to 24.12.0 or later.","what":"CVE-2025-59464 is a medium-severity denial of service vulnerability in Nodejs Node.js, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59464 and fix it if it is affected.\n\nWhat it is: CVE-2025-59464 is a medium-severity denial of service vulnerability in Nodejs Node.js, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59464 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 24.0.0; fixed in 24.12.0\n- node-min (Bitnami): affected from 24.0.0; fixed in 24.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59464/ (Markdown: https://insights.sbomify.com/CVE-2025-59464/index.md)","id":"CVE-2025-59464","markdown":"https://insights.sbomify.com/CVE-2025-59464/index.md","name":"CVE-2025-59464","record":{"aliases":["BELL-CVE-2025-59464","BIT-node-2025-59464","BIT-node-min-2025-59464","CLEANSTART-2026-DI68809","GHSA-38m8-39f8-gq75","MINI-r75q-fhpq-p2mf","UBUNTU-CVE-2025-59464","openSUSE-SU-2026:10311-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js runtime","requires_auth":"none","summary":"Remote attackers can cause memory exhaustion and denial of service in Node.js applications by triggering memory leaks during TLS certificate processing.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"node.js","vendor":"nodejs"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"A memory leak in Node.js’s OpenSSL integration occurs when converting `X.509` certificate fields to UTF-8 without freeing the allocated buffer. When applications call `socket.getPeerCertificate(true)`, each certificate field leaks memory, allowing remote clients to trigger steady memory growth through repeated TLS connections. Over time this can lead to resource exhaustion and denial of service.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in node","id":"CVE-2025-59464","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Denial of service in node","id":"CVE-2025-59465"},"packages":[{"ecosystem":"Bitnami","fixed":["24.12.0"],"introduced":["24.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2025-59464"},{"ecosystem":"Bitnami","fixed":["24.12.0"],"introduced":["24.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2025-59464"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["24.13.0-4.1"],"introduced":["0"],"last_affected":[],"package":"nodejs24","purl":"pkg:rpm/opensuse/nodejs24\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10311-1"}],"prev":{"headline":"Denial-of-service (DoS) via chunk size mismatch","id":"CVE-2025-59463"},"products":["node"],"published":"2026-01-20","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-21","vendors":["nodejs"]},"summary":"Remote attackers can cause memory exhaustion and denial of service in Node.js applications by triggering memory leaks during TLS certificate processing.","url":"https://insights.sbomify.com/CVE-2025-59464/"}