# CVE-2025-59464: Denial of service in node

> Remote attackers can cause memory exhaustion and denial of service in Node.js applications by triggering memory leaks during TLS certificate processing.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** BELL-CVE-2025-59464, BIT-node-2025-59464, BIT-node-min-2025-59464, CLEANSTART-2026-DI68809, GHSA-38m8-39f8-gq75, MINI-r75q-fhpq-p2mf, UBUNTU-CVE-2025-59464, openSUSE-SU-2026:10311-1

## What is CVE-2025-59464?

CVE-2025-59464 is a medium-severity denial of service vulnerability in Nodejs Node.js, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A memory leak in Node.js’s OpenSSL integration occurs when converting `X.509` certificate fields to UTF-8 without freeing the allocated buffer. When applications call `socket.getPeerCertificate(true)`, each certificate field leaks memory, allowing remote clients to trigger steady memory growth through repeated TLS connections. Over time this can lead to resource exhaustion and denial of service.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-59464?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 24.0.0 | 24.12.0 |
| `node-min` | Bitnami | From 24.0.0 | 24.12.0 |
| `nodejs24` | openSUSE:Tumbleweed | All versions | 24.13.0-4.1 |

Products: Nodejs Node.js.

## How do I fix CVE-2025-59464?

Upgrade node to 24.12.0 or later.

## Is CVE-2025-59464 being exploited?

There is no known exploitation of CVE-2025-59464 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59464 and fix it if it is affected.

What it is: CVE-2025-59464 is a medium-severity denial of service vulnerability in Nodejs Node.js, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59464 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 24.0.0; fixed in 24.12.0
- node-min (Bitnami): affected from 24.0.0; fixed in 24.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59464/ (Markdown: https://insights.sbomify.com/CVE-2025-59464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59464
- OSV: https://osv.dev/vulnerability/CVE-2025-59464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59464/
Summaries are generated and may contain mistakes; the official description above is the record.
