CVE-2025-5952 Zend.To NSSDropoff.php exec os command injection

Medium 6.9 Published Updated

Remote attackers can execute arbitrary OS commands via the file_1 argument in NSSDropoff.php, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5952?

CVE-2025-5952 is a medium-severity command injection vulnerability in Zend.To, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability, which was classified as critical, has been found in Zend.To up to 6.10-6 Beta. This issue affects the function exec of the file NSSDropoff.php. The manipulation of the argument file_1 leads to os command injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 6.10-7 is able to address this issue. It is recommended to upgrade the affected component. This affects a rather old version of the software. The vendor recommends updating to the latest release. Additional countermeasures have been added in 6.15-8.

Weakness: CWE-78, CWE-77

Which versions are affected by CVE-2025-5952?

How do I fix CVE-2025-5952?

No fix has been published for CVE-2025-5952 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-5952 being exploited?

There is no known exploitation of CVE-2025-5952 in the wild and no public exploit code.

Sources

Also known as GHSA-rq7g-gmv2-43cj.

Is CVE-2025-5952 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free