{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-5952 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-5952 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-5952 is a medium-severity command injection vulnerability in Zend.To, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5952 and fix it if it is affected.\n\nWhat it is: CVE-2025-5952 is a medium-severity command injection vulnerability in Zend.To, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-5952 in the wild and no public exploit code.\n\nAffected product: Zend.To. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5952/ (Markdown: https://insights.sbomify.com/CVE-2025-5952/index.md)","id":"CVE-2025-5952","markdown":"https://insights.sbomify.com/CVE-2025-5952/index.md","name":"CVE-2025-5952","record":{"aliases":["GHSA-rq7g-gmv2-43cj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Zend.To web application","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands via the file_1 argument in NSSDropoff.php, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability, which was classified as critical, has been found in Zend.To up to 6.10-6 Beta. This issue affects the function exec of the file NSSDropoff.php. The manipulation of the argument file_1 leads to os command injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 6.10-7 is able to address this issue. It is recommended to upgrade the affected component. This affects a rather old version of the software. The vendor recommends updating to the latest release. Additional countermeasures have been added in 6.15-8.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Zend.To NSSDropoff.php exec os command injection","id":"CVE-2025-5952","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":4,"next":{"headline":"Missing authorization in WP Human Resource Management","id":"CVE-2025-5953"},"packages":[],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2025-5951"},"products":["Zend.To"],"published":"2025-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary OS commands via the file_1 argument in NSSDropoff.php, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-5952/"}