# CVE-2025-5952: Zend.To NSSDropoff.php exec os command injection

> Remote attackers can execute arbitrary OS commands via the file_1 argument in NSSDropoff.php, requiring an upgrade to mitigate.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-rq7g-gmv2-43cj

## What is CVE-2025-5952?

CVE-2025-5952 is a medium-severity command injection vulnerability in Zend.To, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in Zend.To up to 6.10-6 Beta. This issue affects the function exec of the file NSSDropoff.php. The manipulation of the argument file_1 leads to os command injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 6.10-7 is able to address this issue. It is recommended to upgrade the affected component. This affects a rather old version of the software. The vendor recommends updating to the latest release. Additional countermeasures have been added in 6.15-8.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-5952?


## How do I fix CVE-2025-5952?

No fix has been published for CVE-2025-5952 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5952 being exploited?

There is no known exploitation of CVE-2025-5952 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5952 and fix it if it is affected.

What it is: CVE-2025-5952 is a medium-severity command injection vulnerability in Zend.To, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-5952 in the wild and no public exploit code.

Affected product: Zend.To. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5952/ (Markdown: https://insights.sbomify.com/CVE-2025-5952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5952
- OSV: https://osv.dev/vulnerability/CVE-2025-5952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5952/
Summaries are generated and may contain mistakes; the official description above is the record.
