# CVE-2025-59526: Mailgen: HTML injection vulnerability in plaintext e-mails

> Attacker can inject HTML into plaintext emails via user input, potentially leading to XSS or data theft in applications using Mailgen.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:L/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-j2xj-h7w5-r7vp

## What is CVE-2025-59526?

CVE-2025-59526 is a low-severity cross-site scripting vulnerability in eladnava mailgen, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mailgen is a Node.js package that generates responsive HTML e-mails for sending transactional mail. Prior to version 2.0.30, there is an HTML injection vulnerability in plaintext e-mails generated by Mailgen. Projects are affected if the Mailgen.generatePlaintext(email) method is used and given user-generated content. This vulnerability has been patched in version 2.0.30. A workaround involves stripping all HTML tags before passing any content into Mailgen.generatePlaintext(email).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59526?

2 open source packages ship an affected version, including mailgen.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailgen` | npm | All versions | 2.0.30 |
| `mailgen` | npm | All versions | 2.0.30 |

## How do I fix CVE-2025-59526?

Upgrade mailgen to 2.0.30 or later.

## Is CVE-2025-59526 being exploited?

There is no known exploitation of CVE-2025-59526 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59526 and fix it if it is affected.

What it is: CVE-2025-59526 is a low-severity cross-site scripting vulnerability in eladnava mailgen, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59526 in the wild and no public exploit code.

Affected packages and fixed versions:
- mailgen (npm): affected all versions; fixed in 2.0.30
- mailgen (npm): affected all versions; fixed in 2.0.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59526/ (Markdown: https://insights.sbomify.com/CVE-2025-59526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59526
- OSV: https://osv.dev/vulnerability/CVE-2025-59526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59526/
Summaries are generated and may contain mistakes; the official description above is the record.
