CVE-2025-59527 FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability

High 7.5 Published Updated

An attacker can exploit an SSRF vulnerability in Flowise to access internal network services and explore link structures via the fetch-links endpoint.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59527?

CVE-2025-59527 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, a Server-Side Request Forgery (SSRF) vulnerability was discovered in the /api/v1/fetch-links endpoint of the Flowise application. This vulnerability allows an attacker to use the Flowise server as a proxy to access internal network web services and explore their link structures. This issue has been patched in version 3.0.6.

Weakness: CWE-918

Which versions are affected by CVE-2025-59527?

2 open source packages ship an affected version, including flowise. It affects 1 product.

PackageAffectedFixed in
flowise npmFrom 3.0.53.0.6
flowise npmFrom 3.0.53.0.6

Products include Flowiseai Flowise.

How do I fix CVE-2025-59527?

Upgrade flowise to 3.0.6 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-59527 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59527 exists.

All Flowiseai Flowise vulnerabilities

Sources

Also known as GHSA-hr92-4q35-4j3m.

Is CVE-2025-59527 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free