{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59527 exists.","fix":"Upgrade flowise to 3.0.6 or later.","what":"CVE-2025-59527 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59527 and fix it if it is affected.\n\nWhat it is: CVE-2025-59527 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59527 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected from 3.0.5; fixed in 3.0.6\n- flowise (npm): affected from 3.0.5; fixed in 3.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59527/ (Markdown: https://insights.sbomify.com/CVE-2025-59527/index.md)","id":"CVE-2025-59527","markdown":"https://insights.sbomify.com/CVE-2025-59527/index.md","name":"CVE-2025-59527","record":{"aliases":["GHSA-hr92-4q35-4j3m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"none","summary":"An attacker can exploit an SSRF vulnerability in Flowise to access internal network services and explore link structures via the fetch-links endpoint.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. In version 3.0.5, a Server-Side Request Forgery (SSRF) vulnerability was discovered in the /api/v1/fetch-links endpoint of the Flowise application. This vulnerability allows an attacker to use the Flowise server as a proxy to access internal network web services and explore their link structures. This issue has been patched in version 3.0.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability","id":"CVE-2025-59527","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"ssrf","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528"},"packages":[{"ecosystem":"npm","fixed":["3.0.6"],"introduced":["3.0.5"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-hr92-4q35-4j3m"},{"ecosystem":"npm","fixed":["3.0.6"],"introduced":["3.0.5"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-hr92-4q35-4j3m"}],"prev":{"headline":"Mailgen: HTML injection vulnerability in plaintext e-mails","id":"CVE-2025-59526"},"products":["Flowise"],"published":"2025-09-22","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-22","vendors":["FlowiseAI"]},"summary":"An attacker can exploit an SSRF vulnerability in Flowise to access internal network services and explore link structures via the fetch-links endpoint.","url":"https://insights.sbomify.com/CVE-2025-59527/"}