# CVE-2025-59527: FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability

> An attacker can exploit an SSRF vulnerability in Flowise to access internal network services and explore link structures via the fetch-links endpoint.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-hr92-4q35-4j3m

## What is CVE-2025-59527?

CVE-2025-59527 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, a Server-Side Request Forgery (SSRF) vulnerability was discovered in the /api/v1/fetch-links endpoint of the Flowise application. This vulnerability allows an attacker to use the Flowise server as a proxy to access internal network web services and explore their link structures. This issue has been patched in version 3.0.6.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-59527?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | From 3.0.5 | 3.0.6 |
| `flowise` | npm | From 3.0.5 | 3.0.6 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-59527?

Upgrade flowise to 3.0.6 or later.

## Is CVE-2025-59527 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59527 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59527 and fix it if it is affected.

What it is: CVE-2025-59527 is a high-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59527 exists.

Affected packages and fixed versions:
- flowise (npm): affected from 3.0.5; fixed in 3.0.6
- flowise (npm): affected from 3.0.5; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59527/ (Markdown: https://insights.sbomify.com/CVE-2025-59527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59527
- OSV: https://osv.dev/vulnerability/CVE-2025-59527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59527/
Summaries are generated and may contain mistakes; the official description above is the record.
