CVE-2025-59528 Flowise has Remote Code Execution vulnerability
Attackers can execute arbitrary JavaScript code via the CustomMCP node configuration, leading to remote code execution on the server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-59528?
CVE-2025-59528 is a critical code injection vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, Flowise is vulnerable to remote code execution. The CustomMCP node allows users to input configuration settings for connecting to an external MCP server. This node parses the user-provided mcpServerConfig string to build the MCP server configuration. However, during this process, it executes JavaScript code without any security validation. Specifically, inside the convertToValidJSONString function, user input is directly passed to the Function() constructor, which evaluates and executes the input as JavaScript code. Since this runs with full Node.js runtime privileges, it can access dangerous modules such as child_process and fs. This issue has been patched in version 3.0.6.
Weakness: CWE-94
Which versions are affected by CVE-2025-59528?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | From 3.0.5 | 3.0.6 |
flowise npm | From 3.0.5 | 3.0.6 |
Products include Flowiseai Flowise.
How do I fix CVE-2025-59528?
Upgrade flowise to 3.0.6 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-59528 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59528 exists.
Public exploit code: 1 Metasploit module, 1 Exploit-DB entry, 1 Nuclei template and 13 proofs of concept on GitHub.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2026-52098 Code injection in n/a
- CVE-2025-58434 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover
Sources
Also known as GHSA-3gcm-f6qx-ff7p.