# CVE-2025-59528: Flowise has Remote Code Execution vulnerability

> Attackers can execute arbitrary JavaScript code via the CustomMCP node configuration, leading to remote code execution on the server.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-3gcm-f6qx-ff7p

## What is CVE-2025-59528?

CVE-2025-59528 is a critical code injection vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, Flowise is vulnerable to remote code execution. The CustomMCP node allows users to input configuration settings for connecting to an external MCP server. This node parses the user-provided mcpServerConfig string to build the MCP server configuration. However, during this process, it executes JavaScript code without any security validation. Specifically, inside the convertToValidJSONString function, user input is directly passed to the Function() constructor, which evaluates and executes the input as JavaScript code. Since this runs with full Node.js runtime privileges, it can access dangerous modules such as child_process and fs. This issue has been patched in version 3.0.6.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-59528?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | From 3.0.5 | 3.0.6 |
| `flowise` | npm | From 3.0.5 | 3.0.6 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-59528?

Upgrade flowise to 3.0.6 or later.

## Is CVE-2025-59528 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59528 exists.

Public exploit code:

- CVE-2025-59528 - FlowiseAI CustomMCP Remote Code Execution (github_poc): https://github.com/UsifAraby/CVE-2025-59528-POC
- CVE-2025-59528 Proof of Concept (github_poc): https://github.com/vanhari/CVE-2025-59528
- A simple python script to exploit CVE-2025-59528, this an Authenticated RCE vulnerability in Flowise application, a popular AI tool. That is also used in HTB seasonal challenge. The issue is present in version <= 3.0.5, for more details: https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-3gcm-f6qx-ff7p (github_poc): https://github.com/maradonam18/-CVE-2025-59528-PoC
- Authenticated Remote Code Execution (RCE) exploit for Flowise AI versions ≤ 3.0.4. Leverages a vulnerability in the /api/v1/node-load-method/customMCP endpoint to execute arbitrary system commands via Node.js child_process.execSync(). Includes full PoC script and remediation steps. (github_poc): https://github.com/arensballiu/Flowise-RCE-CVE-2025-59528
- CVE-2025-59528 Proof of Concept (github_poc): https://github.com/mananispiwpiw/CVE-2025-59528-PoC
- Technical PoC for CVE-2025-59528 (Flowise < 3.0.5), demonstrating authenticated RCE through customMCP mcpServerConfig injection, with clear bilingual documentation and reproducible steps for authorized security testing. (github_poc): https://github.com/NymiiTechTips/CVE-2025-59528

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)
- [CVE-2025-58434](https://insights.sbomify.com/CVE-2025-58434/): Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59528 and fix it if it is affected.

What it is: CVE-2025-59528 is a critical code injection vulnerability in Flowiseai Flowise, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59528 exists.

Affected packages and fixed versions:
- flowise (npm): affected from 3.0.5; fixed in 3.0.6
- flowise (npm): affected from 3.0.5; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59528/ (Markdown: https://insights.sbomify.com/CVE-2025-59528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59528
- OSV: https://osv.dev/vulnerability/CVE-2025-59528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59528/
Summaries are generated and may contain mistakes; the official description above is the record.
