# CVE-2025-59530: quic-go has Client Crash Due to Premature HANDSHAKE_DONE Frame

> A malicious server can crash the quic-go client by sending a premature HANDSHAKE_DONE frame, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2025
- **Updated:** 10 Oct 2025
- **Also known as:** AZL-68778, AZL-68781, CLEANSTART-2026-BK21255, CLEANSTART-2026-BR56941, CLEANSTART-2026-II99351, DEBIAN-CVE-2025-59530, GHSA-47m2-4cr7-mhcw, GO-2025-4017, MINI-2pmr-f66j-j484, MINI-3967-98j7-cgw5, MINI-6f4r-pw9f-ccxp, MINI-9pfh-r379-frgr, MINI-9r58-vx6x-vv8m, MINI-9xvf-g272-xjch, MINI-f6qv-3fxc-7vhc, MINI-hvgx-cv6c-6hhm, MINI-jhx7-gv58-vm4m, MINI-m2xx-79m7-63pq, MINI-m5v8-2m5m-fq36, MINI-mx85-2mpq-m8q2, MINI-r2vh-j5f2-4jxc, MINI-v5qr-cc7w-rvqp, MINI-v8hj-j6hc-54vg, MINI-vhxh-x9mp-jg5p, MINI-vmm6-8gh8-63qw, MINI-vvg5-86pj-mp36, MINI-xqcc-gr9r-c99v, RHSA-2025:21706, UBUNTU-CVE-2025-59530, openSUSE-SU-2025:15737-1

## What is CVE-2025-59530?

CVE-2025-59530 is a high-severity denial of service vulnerability in quic-go, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

quic-go is an implementation of the QUIC protocol in Go. In versions prior to 0.49.0, 0.54.1, and 0.55.0, a misbehaving or malicious server can cause a denial-of-service (DoS) attack on the quic-go client by triggering an assertion failure, leading to a process crash. This requires no authentication and can be exploited during the handshake phase. This was observed in the wild with certain server implementations. quic-go needs to be able to handle misbehaving server implementations, including those that prematurely send a HANDSHAKE_DONE frame. Versions 0.49.0, 0.54.1, and 0.55.0 discard Initial keys when receiving a HANDSHAKE_DONE frame, thereby correctly handling premature HANDSHAKE_DONE frames.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2025-59530?

5 open source packages ship an affected version, including github.com/quic-go/quic-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/quic-go/quic-go` | Go | All versions | 0.49.1, 0.54.1 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.49.1 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.49.1 |
| `github.com/quic-go/quic-go` | Go | From 0.50.0 | 0.54.1 |
| `github.com/quic-go/quic-go` | Go | From 0.50.0 | 0.54.1 |
| `receptor` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptor-debuginfo` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptor-debugsource` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptorctl` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptor` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptor-debuginfo` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptor-debugsource` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptorctl` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptor` | Red Hat:ansible_automation_platform_developer:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptorctl` | Red Hat:ansible_automation_platform_developer:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptor` | Red Hat:ansible_automation_platform_developer:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptorctl` | Red Hat:ansible_automation_platform_developer:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptor` | Red Hat:ansible_automation_platform_inside:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptorctl` | Red Hat:ansible_automation_platform_inside:2.4::el8 | All versions | 0:1.6.2-1.el8ap |
| `receptor` | Red Hat:ansible_automation_platform_inside:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `receptorctl` | Red Hat:ansible_automation_platform_inside:2.4::el9 | All versions | 0:1.6.2-1.el9ap |
| `teleport` | openSUSE:Tumbleweed | All versions | 17.7.10-1.1 |

## How do I fix CVE-2025-59530?

Upgrade github.com/quic-go/quic-go to a fixed version for your release line: 0.49.1 or 0.54.1.

## Is CVE-2025-59530 being exploited?

There is no known exploitation of CVE-2025-59530 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59530 and fix it if it is affected.

What it is: CVE-2025-59530 is a high-severity denial of service vulnerability in quic-go, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59530 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.49.1, 0.54.1
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.49.1
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.49.1
- github.com/quic-go/quic-go (Go): affected from 0.50.0; fixed in 0.54.1
- github.com/quic-go/quic-go (Go): affected from 0.50.0; fixed in 0.54.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59530/ (Markdown: https://insights.sbomify.com/CVE-2025-59530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59530
- OSV: https://osv.dev/vulnerability/CVE-2025-59530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59530/
Summaries are generated and may contain mistakes; the official description above is the record.
