{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59548 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-59548 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59548 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59548 and fix it if it is affected.\n\nWhat it is: CVE-2025-59548 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59548 in the wild and no public exploit code.\n\nAffected product: Dnnsoftware Dotnetnuke. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59548/ (Markdown: https://insights.sbomify.com/CVE-2025-59548/index.md)","id":"CVE-2025-59548","markdown":"https://insights.sbomify.com/CVE-2025-59548/index.md","name":"CVE-2025-59548","record":{"aliases":["GHSA-5fj9-542v-w4rq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DNN CMS","requires_auth":"high_privilege","summary":"Attackers can inject JavaScript via crafted URLs in the CKEditor File Browser, potentially compromising user sessions in DNN CMS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, specially crafted URLs to the FileBrowser are vulnerable to javascript injection, affecting any unsuspecting user clicking such link. This issue has been patched in version 10.1.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"DNN Vulnerable to Reflected Cross-Site Scripting (XSS) in CKEditor File Browser","id":"CVE-2025-59548","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"xss","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"WordPress GetResponse Forms Plugin \u003c= 2.6.0 - Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-59549"},"packages":[],"prev":{"headline":"DNN's CKEditor File Uploader functionality vulnerable through Unicode obfuscation","id":"CVE-2025-59547"},"products":["Dnn.Platform"],"published":"2025-09-23","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-23","vendors":["dnnsoftware"]},"summary":"Attackers can inject JavaScript via crafted URLs in the CKEditor File Browser, potentially compromising user sessions in DNN CMS.","url":"https://insights.sbomify.com/CVE-2025-59548/"}