CVE-2025-59681 Django vulnerable to SQL injection in column aliases

High 7.1 Published Updated

Attackers can execute SQL injection via crafted dictionary arguments in Django QuerySet methods on MySQL and MariaDB databases.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59681?

CVE-2025-59681 is a high-severity SQL injection vulnerability in Djangoproject Django, published on 1 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in Django 4.2 before 4.2.25, 5.1 before 5.1.13, and 5.2 before 5.2.7. QuerySet.annotate(), QuerySet.alias(), QuerySet.aggregate(), and QuerySet.extra() are subject to SQL injection in column aliases, when using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed to these methods (on MySQL and MariaDB).

Weakness: CWE-89

Which versions are affected by CVE-2025-59681?

8 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django BitnamiFrom 4.2.04.2.25, 5.1.13, 5.2.7
django PyPIFrom 4.24.2.25, 5.1.13, 5.2.7
django PyPIFrom 4.24.2.25
django PyPIFrom 5.15.1.13
django PyPIFrom 5.25.2.7
Django PyPIFrom 4.24.2.25
2 more packages
Django PyPIFrom 5.15.1.13
Django PyPIFrom 5.25.2.7

Products include Djangoproject Django.

How do I fix CVE-2025-59681?

Upgrade django to a fixed version for your release line: 4.2.25, 5.1.13 or 5.2.7.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-59681 being exploited?

There is no known exploitation of CVE-2025-59681 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as BIT-django-2025-59681, DEBIAN-CVE-2025-59681, ECHO-5818-1fba-950a, GHSA-hpr9-3m2g-3j9p, PYSEC-2025-106, UBUNTU-CVE-2025-59681.

Is CVE-2025-59681 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free