# CVE-2025-59681: Django vulnerable to SQL injection in column aliases

> Attackers can execute SQL injection via crafted dictionary arguments in Django QuerySet methods on MySQL and MariaDB databases.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-django-2025-59681, DEBIAN-CVE-2025-59681, ECHO-5818-1fba-950a, GHSA-hpr9-3m2g-3j9p, PYSEC-2025-106, UBUNTU-CVE-2025-59681

## What is CVE-2025-59681?

CVE-2025-59681 is a high-severity SQL injection vulnerability in Djangoproject Django, published on 1 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Django 4.2 before 4.2.25, 5.1 before 5.1.13, and 5.2 before 5.2.7. QuerySet.annotate(), QuerySet.alias(), QuerySet.aggregate(), and QuerySet.extra() are subject to SQL injection in column aliases, when using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed to these methods (on MySQL and MariaDB).

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-59681?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.25, 5.1.13, 5.2.7 |
| `django` | PyPI | From 4.2 | 4.2.25, 5.1.13, 5.2.7 |
| `django` | PyPI | From 4.2 | 4.2.25 |
| `django` | PyPI | From 5.1 | 5.1.13 |
| `django` | PyPI | From 5.2 | 5.2.7 |
| `Django` | PyPI | From 4.2 | 4.2.25 |
| `Django` | PyPI | From 5.1 | 5.1.13 |
| `Django` | PyPI | From 5.2 | 5.2.7 |

Products: Djangoproject Django.

## How do I fix CVE-2025-59681?

Upgrade django to a fixed version for your release line: 4.2.25, 5.1.13 or 5.2.7.

## Is CVE-2025-59681 being exploited?

There is no known exploitation of CVE-2025-59681 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59681 and fix it if it is affected.

What it is: CVE-2025-59681 is a high-severity SQL injection vulnerability in Djangoproject Django, published on 1 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59681 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.25, 5.1.13, 5.2.7
- django (PyPI): affected from 4.2; fixed in 4.2.25, 5.1.13, 5.2.7
- django (PyPI): affected from 4.2; fixed in 4.2.25
- django (PyPI): affected from 5.1; fixed in 5.1.13
- django (PyPI): affected from 5.2; fixed in 5.2.7
- Django (PyPI): affected from 4.2; fixed in 4.2.25
- Django (PyPI): affected from 5.1; fixed in 5.1.13
- Django (PyPI): affected from 5.2; fixed in 5.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59681/ (Markdown: https://insights.sbomify.com/CVE-2025-59681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59681
- OSV: https://osv.dev/vulnerability/CVE-2025-59681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59681/
Summaries are generated and may contain mistakes; the official description above is the record.
