# CVE-2025-59694: Security feature bypass in n/a

> A physically proximate attacker can persistently modify firmware and bypass secure boot on Entrust nShield HSMs via JTAG or firmware upgrades.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Dec 2025
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-7gqq-6vwr-4g3v

## What is CVE-2025-59694?

CVE-2025-59694 is a medium-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Chassis Management Board in Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allows a physically proximate attacker to persistently modify firmware and influence the (insecurely configured) appliance boot process. To exploit this, the attacker must modify the firmware via JTAG or perform an upgrade to the chassis management board firmware. This is called F03.

Weakness: CWE-1274 (Improper Access Control for Volatile Memory Containing Boot Code)

## Which versions are affected by CVE-2025-59694?

It affects 5 products.


Products: Entrust Nshield 5c Firmware, Entrust Nshield Connect Xc Base Firmware, Entrust Nshield Connect Xc High Firmware, Entrust Nshield Connect Xc Mid Firmware, Entrust Nshield Hsmi Firmware.

## How do I fix CVE-2025-59694?

No fix has been published for CVE-2025-59694 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59694 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59694 exists.

## Other vulnerabilities in n/a

- [CVE-2025-59693](https://insights.sbomify.com/CVE-2025-59693/): Security feature bypass in n/a (critical 9.8)
- [CVE-2025-59695](https://insights.sbomify.com/CVE-2025-59695/): Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allow a user (critical 9.8)
- [CVE-2025-59703](https://insights.sbomify.com/CVE-2025-59703/): Security feature bypass in n/a (critical 9.1)
- [CVE-2025-59704](https://insights.sbomify.com/CVE-2025-59704/): Auth bypass in n/a (high 7.8)
- [CVE-2025-59697](https://insights.sbomify.com/CVE-2025-59697/): Privilege escalation in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59694 and fix it if it is affected.

What it is: CVE-2025-59694 is a medium-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59694 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59694/ (Markdown: https://insights.sbomify.com/CVE-2025-59694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59694
- OSV: https://osv.dev/vulnerability/CVE-2025-59694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59694/
Summaries are generated and may contain mistakes; the official description above is the record.
