CVE-2025-59697 Privilege escalation in n/a

High 7.2 Published Updated

A physically proximate attacker can escalate privileges to root by editing the GRUB bootloader configuration on nShield HSM devices.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-59697?

CVE-2025-59697 is a high-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allow a physically proximate attacker to escalate privileges by editing the Legacy GRUB bootloader configuration to start a root shell upon boot of the host OS. This is called F06.

Weakness: CWE-284, CWE-269

Which versions are affected by CVE-2025-59697?

It affects 5 products.

Products include Entrust Nshield 5c Firmware, Entrust Nshield Connect Xc Base Firmware, Entrust Nshield Connect Xc High Firmware, Entrust Nshield Connect Xc Mid Firmware, Entrust Nshield Hsmi Firmware.

How do I fix CVE-2025-59697?

No fix has been published for CVE-2025-59697 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-59697 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59697 exists.

Sources

Also known as GHSA-c2xm-xv33-q796.

Is CVE-2025-59697 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free