CVE-2025-59698 Security feature bypass in n/a

Medium 6.8 Published Updated

A physically proximate attacker can bypass security controls to access the legacy bootloader on Entrust nShield HSMs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-59698?

CVE-2025-59698 is a medium-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), might allow a physically proximate attacker to gain access to the EOL legacy bootloader.

Weakness: CWE-1270

Which versions are affected by CVE-2025-59698?

It affects 5 products.

Products include Entrust Nshield 5c Firmware, Entrust Nshield Connect Xc Base Firmware, Entrust Nshield Connect Xc High Firmware, Entrust Nshield Connect Xc Mid Firmware, Entrust Nshield Hsmi Firmware.

How do I fix CVE-2025-59698?

No fix has been published for CVE-2025-59698 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-59698 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59698 exists.

Sources

Also known as GHSA-cjjw-86jv-h24c.

Is CVE-2025-59698 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free