CVE-2025-59699 Privilege escalation in n/a

Medium 6.8 Published Updated

A physically proximate attacker can escalate privileges on Entrust nShield HSMs by booting from a USB device due to insecure GRUB bootloader defaults.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-59699?

CVE-2025-59699 is a medium-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allow a physically proximate attacker to escalate privileges by booting from a USB device with a valid root filesystem. This occurs because of insecure default settings in the Legacy GRUB Bootloader.

Weakness: CWE-290

Which versions are affected by CVE-2025-59699?

It affects 5 products.

Products include Entrust Nshield 5c Firmware, Entrust Nshield Connect Xc Base Firmware, Entrust Nshield Connect Xc High Firmware, Entrust Nshield Connect Xc Mid Firmware, Entrust Nshield Hsmi Firmware.

How do I fix CVE-2025-59699?

No fix has been published for CVE-2025-59699 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-59699 being exploited?

There is no known exploitation of CVE-2025-59699 in the wild and no public exploit code.

Sources

Also known as GHSA-g9v7-h8x8-w5vw.

Is CVE-2025-59699 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free