# CVE-2025-59700: Security feature bypass in n/a

> A physically proximate attacker with root access can bypass integrity protections to modify the Recovery Partition on nShield HSMs.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Dec 2025
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-qmq3-q8h7-g3v7

## What is CVE-2025-59700?

CVE-2025-59700 is a medium-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allow a physically proximate attacker with root access to modify the Recovery Partition (because of a lack of integrity protection).

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2025-59700?

It affects 5 products.


Products: Entrust Nshield 5c Firmware, Entrust Nshield Connect Xc Base Firmware, Entrust Nshield Connect Xc High Firmware, Entrust Nshield Connect Xc Mid Firmware, Entrust Nshield Hsmi Firmware.

## How do I fix CVE-2025-59700?

No fix has been published for CVE-2025-59700 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59700 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59700 exists.

## Other vulnerabilities in n/a

- [CVE-2025-59693](https://insights.sbomify.com/CVE-2025-59693/): Security feature bypass in n/a (critical 9.8)
- [CVE-2025-59695](https://insights.sbomify.com/CVE-2025-59695/): Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allow a user (critical 9.8)
- [CVE-2025-59703](https://insights.sbomify.com/CVE-2025-59703/): Security feature bypass in n/a (critical 9.1)
- [CVE-2025-59704](https://insights.sbomify.com/CVE-2025-59704/): Auth bypass in n/a (high 7.8)
- [CVE-2025-59697](https://insights.sbomify.com/CVE-2025-59697/): Privilege escalation in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59700 and fix it if it is affected.

What it is: CVE-2025-59700 is a medium-severity vulnerability in n/a, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59700 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59700/ (Markdown: https://insights.sbomify.com/CVE-2025-59700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59700
- OSV: https://osv.dev/vulnerability/CVE-2025-59700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59700/
Summaries are generated and may contain mistakes; the official description above is the record.
