CVE-2025-59712 Snipe-IT allows XSS
Medium 6.4
Published
Updated
Check this codebase for CVE-2025-59712 and fix it if it is affected.
What it is: CVE-2025-59712 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 19 Sep 2025.
Exploitation: There is no known exploitation of CVE-2025-59712 in the wild and no public exploit code.
Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.1.18
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.1.18
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2025-59712/ (Markdown: https://insights.sbomify.com/CVE-2025-59712/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-59712?
CVE-2025-59712 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 19 Sep 2025.
Official description
Snipe-IT before 8.1.18 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2025-59712?
2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snipe/snipe-it Packagist | All versions | 8.1.18 |
snipe/snipe-it Packagist | All versions | 8.1.18 |
Products include Snipeitapp Snipe-It.
How do I fix CVE-2025-59712?
Upgrade snipe/snipe-it to 8.1.18 or later.
Is CVE-2025-59712 being exploited?
There is no known exploitation of CVE-2025-59712 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Snipeitapp Snipe-It
- CVE-2025-63601 File upload in n/a
- CVE-2026-37709 Snipe-IT has insecure permissions in file uploads
- CVE-2026-86738 Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- CVE-2026-116199 Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback
- CVE-2022-1380 Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it
Sources
Also known as GHSA-c9wp-pr7f-hfqm.