CVE-2025-59775 Apache HTTP Server: NTLM Leakage on Windows through UNC SSRF

High 7.5 Published Updated

Attackers can leak NTLM hashes via SSRF on Windows Apache servers with specific non-default slash handling configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59775?

CVE-2025-59775 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Server-Side Request Forgery (SSRF) vulnerability

 in Apache HTTP Server on Windows

with AllowEncodedSlashes On and MergeSlashes Off  allows to potentially leak NTLM hashes to a malicious server via SSRF and malicious requests or content

Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Weakness: CWE-918

Which versions are affected by CVE-2025-59775?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.66

Products include Apache Http Server.

How do I fix CVE-2025-59775?

Upgrade apache to 2.4.66 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-59775 being exploited?

There is no known exploitation of CVE-2025-59775 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2025-59775, BELL-CVE-2025-59775, BIT-apache-2025-59775, GHSA-7w72-74p3-5cfq, MINI-94h9-w4gf-6chr.

Is CVE-2025-59775 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free