# CVE-2025-59789: Apache bRPC: Stack Exhaustion via Unbounded Recursion in JSON Parser

> Remote attackers can crash Apache bRPC servers by sending deeply nested JSON data, causing stack exhaustion in the JSON parser.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Dec 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-x4fp-gjpv-c6r5

## What is CVE-2025-59789?

CVE-2025-59789 is a high-severity denial of service vulnerability in Apache bRPC, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled recursion in the json2pb component in Apache bRPC (version < 1.15.0) on all platforms allows remote attackers to make the server crash via sending deep recursive json data.

Root Cause:
The bRPC json2pb component uses rapidjson to parse json data from the network. The rapidjson parser uses a recursive parsing method by default. If the input json has a large depth of recursive structure, the parser function may run into stack overflow.

Affected Scenarios:
Use bRPC server with protobuf message to serve http+json requests from untrusted network. Or directly use JsonToProtoMessage to convert json from untrusted input.

How to Fix: 
(Choose one of the following options) 
1. Upgrade bRPC to version 1.15.0, which fixes this issue.
2. Apply this patch:  https://github.com/apache/brpc/pull/3099 

Note:
No matter which option 

you choose, you should know that the fix introduces a recursion depth limit with default value 100. It affects these functions: 

ProtoMessageToJson, ProtoMessageToProtoJson, JsonToProtoMessage, and ProtoJsonToProtoMessage.

 If your requests contain json or protobuf messages that have a depth exceeding the limit, the request will be failed after applying the fix. You can modify the gflag json2pb_max_recursion_depth to change the limit.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2025-59789?

It affects 1 product.


Products: Apache Brpc.

## How do I fix CVE-2025-59789?

No fix has been published for CVE-2025-59789 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59789 being exploited?

There is no known exploitation of CVE-2025-59789 in the wild and no public exploit code.

## Other vulnerabilities in Apache bRPC

- [CVE-2025-60021](https://insights.sbomify.com/CVE-2025-60021/): Apache bRPC: Remote command injection vulnerability in heap builtin service (critical 9.8)
- [CVE-2023-31039](https://insights.sbomify.com/CVE-2023-31039/): Apache bRPC: ServerOptions.pid_file may cause arbitrary code execution (critical 9.8)
- [CVE-2025-54472](https://insights.sbomify.com/CVE-2025-54472/): Apache bRPC: Redis Parser Remote Denial of Service (high 7.5)
- [CVE-2024-23452](https://insights.sbomify.com/CVE-2024-23452/): Apache bRPC: HTTP request smuggling vulnerability (high 7.5)
- [CVE-2023-45757](https://insights.sbomify.com/CVE-2023-45757/): Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59789 and fix it if it is affected.

What it is: CVE-2025-59789 is a high-severity denial of service vulnerability in Apache bRPC, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59789 in the wild and no public exploit code.

Affected product: Apache bRPC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59789/ (Markdown: https://insights.sbomify.com/CVE-2025-59789/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59789
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59789
- OSV: https://osv.dev/vulnerability/CVE-2025-59789

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59789/
Summaries are generated and may contain mistakes; the official description above is the record.
