CVE-2025-59792 Apache Kvrocks: MONITOR command reveals plaintext credentials to non-admins
Medium 5.3
Published
Updated
Check this codebase for CVE-2025-59792 and fix it if it is affected.
What it is: CVE-2025-59792 is a medium-severity vulnerability in Apache Kvrocks, published on 28 Nov 2025.
Exploitation: There is no known exploitation of CVE-2025-59792 in the wild and no public exploit code.
Affected product: Apache Kvrocks. No package-level version data is available, so check the vendor advisory linked from the reference page.
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2025-59792/ (Markdown: https://insights.sbomify.com/CVE-2025-59792/index.md)
- Exploited in the wild
- Not known
- Fix
- None listed
What is CVE-2025-59792?
CVE-2025-59792 is a medium-severity vulnerability in Apache Kvrocks, published on 28 Nov 2025.
Official description
Reveals plaintext credentials in the MONITOR command vulnerability in Apache Kvrocks.
This issue affects Apache Kvrocks: from 1.0.0 through 2.13.0.
Users are recommended to upgrade to version 2.14.0, which fixes the issue.
Weakness: CWE-312
Which versions are affected by CVE-2025-59792?
It affects 1 product.
Products include Apache Kvrocks.
How do I fix CVE-2025-59792?
No fix has been published for CVE-2025-59792 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-59792 being exploited?
There is no known exploitation of CVE-2025-59792 in the wild and no public exploit code.
Other vulnerabilities in Apache Kvrocks
Sources
Also known as GHSA-h932-5cw5-54j3.