# CVE-2025-59802: Security feature bypass in n/a

> Attackers can modify visible content in signed PDFs without invalidating the digital signature by exploiting Optional Content Group visibility flaws.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-rr6v-3f8x-4hwg

## What is CVE-2025-59802?

CVE-2025-59802 is a high-severity vulnerability in Foxit Pdf Editor, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Foxit PDF Editor and Reader before 2025.2.1 allow signature spoofing via OCG. When Optional Content Groups (OCG) are supported, the state property of an OCG is runtime-only and not included in the digital signature computation buffer. An attacker can leverage JavaScript or PDF triggers to dynamically change the visibility of OCG content after signing (Post-Sign), allowing the visual content of a signed PDF to be modified without invalidating the signature. This may result in a mismatch between the signed content and what the signer or verifier sees, undermining the trustworthiness of the digital signature. The fixed versions are 2025.2.1, 14.0.1, and 13.2.1.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-59802?

It affects 2 products.


Products: Foxit Pdf Editor, Foxit Pdf Reader.

## How do I fix CVE-2025-59802?

No fix has been published for CVE-2025-59802 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59802 being exploited?

There is no known exploitation of CVE-2025-59802 in the wild and no public exploit code.

## Other vulnerabilities in Foxit Pdf Editor

- [CVE-2022-28104](https://insights.sbomify.com/CVE-2022-28104/): File upload in n/a (critical 9.8)
- [CVE-2022-24954](https://insights.sbomify.com/CVE-2022-24954/): Memory corruption in n/a (critical 9.8)
- [CVE-2022-24955](https://insights.sbomify.com/CVE-2022-24955/): Other in n/a (critical 9.8)
- [CVE-2026-91798](https://insights.sbomify.com/CVE-2026-91798/): Foxit PDF Editor/Reader Updater Privilege Escalation (high 8.8)
- [CVE-2026-91800](https://insights.sbomify.com/CVE-2026-91800/): Foxit PDF Editor installer local privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59802 and fix it if it is affected.

What it is: CVE-2025-59802 is a high-severity vulnerability in Foxit Pdf Editor, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59802 in the wild and no public exploit code.

Affected product: Foxit Pdf Editor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59802/ (Markdown: https://insights.sbomify.com/CVE-2025-59802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59802
- OSV: https://osv.dev/vulnerability/CVE-2025-59802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59802/
Summaries are generated and may contain mistakes; the official description above is the record.
