# CVE-2025-59821: DNN vulnerable to Reflected Cross-Site Scripting (XSS) using url to profile

> Attackers can inject malicious scripts into user profiles via crafted URLs, allowing execution in victim browsers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2025
- **Updated:** 23 Sep 2025
- **Also known as:** GHSA-jc4g-c8ww-5738

## What is CVE-2025-59821?

CVE-2025-59821 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, DNN’s URL/path handling and template rendering can allow specially crafted input to be reflected into a user profile that is returned to the browser. In these cases, the application does not sufficiently neutralize or encode characters that are meaningful in HTML, so an attacker can cause a victim’s browser to interpret attacker-controlled content as part of the page’s HTML. This issue has been patched in version 10.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59821?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 10.1.0 |
| `DotNetNuke.Core` | NuGet | All versions | 10.1.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2025-59821?

Upgrade DotNetNuke.Core to 10.1.0 or later.

## Is CVE-2025-59821 being exploited?

There is no known exploitation of CVE-2025-59821 in the wild and no public exploit code.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59821 and fix it if it is affected.

What it is: CVE-2025-59821 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59821 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 10.1.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 10.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59821/ (Markdown: https://insights.sbomify.com/CVE-2025-59821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59821
- OSV: https://osv.dev/vulnerability/CVE-2025-59821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59821/
Summaries are generated and may contain mistakes; the official description above is the record.
