# CVE-2025-59823: Gardener providers vulnerable to code injection when Terraformer is used for infrastructure provisioning

> Administrative users can inject code via Terraformer to gain control over the seed cluster in Gardener Kubernetes management.

- **Severity:** Critical 9.9 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2025
- **Updated:** 29 Sep 2025
- **Also known as:** GHSA-227x-7mh8-3cf6, GO-2025-3981

## What is CVE-2025-59823?

CVE-2025-59823 is a critical code injection vulnerability in gardener-extension-provider-aws, published on 25 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Project Gardener implements the automated management and operation of Kubernetes clusters as a service. Code injection may be possible in Gardener Extensions for AWS providers prior to version 1.64.0, Azure providers prior to version 1.55.0, OpenStack providers prior to version 1.49.0, and GCP providers prior to version 1.46.0. This vulnerability could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster where the shoot cluster is managed. This affects all Gardener installations where Terraformer is used/can be enabled for infrastructure provisioning with any of the affected components. This issue has been patched in Gardener Extensions for AWS providers version 1.64.0, Azure providers version 1.55.0, OpenStack providers version 1.49.0, and GCP providers version 1.46.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-59823?

12 open source packages ship an affected version, including github.com/gardener/gardener-extension-provider-aws, github.com/gardener/gardener-extension-provider-azure and github.com/gardener/gardener-extension-provider-gcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gardener/gardener-extension-provider-aws` | Go | All versions | 1.64.0 |
| `github.com/gardener/gardener-extension-provider-aws` | Go | All versions | 1.64.0 |
| `github.com/gardener/gardener-extension-provider-aws` | Go | All versions | 1.64.0 |
| `github.com/gardener/gardener-extension-provider-azure` | Go | All versions | 1.55.0 |
| `github.com/gardener/gardener-extension-provider-azure` | Go | All versions | 1.55.0 |
| `github.com/gardener/gardener-extension-provider-azure` | Go | All versions | 1.55.0 |
| `github.com/gardener/gardener-extension-provider-gcp` | Go | All versions | 1.46.0 |
| `github.com/gardener/gardener-extension-provider-gcp` | Go | All versions | 1.46.0 |
| `github.com/gardener/gardener-extension-provider-gcp` | Go | All versions | 1.46.0 |
| `github.com/gardener/gardener-extension-provider-openstack` | Go | All versions | 1.49.0 |
| `github.com/gardener/gardener-extension-provider-openstack` | Go | All versions | 1.49.0 |
| `github.com/gardener/gardener-extension-provider-openstack` | Go | All versions | 1.49.0 |

## How do I fix CVE-2025-59823?

Upgrade github.com/gardener/gardener-extension-provider-aws to 1.64.0 or later.

## Is CVE-2025-59823 being exploited?

There is no known exploitation of CVE-2025-59823 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59823 and fix it if it is affected.

What it is: CVE-2025-59823 is a critical code injection vulnerability in gardener-extension-provider-aws, published on 25 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59823 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gardener/gardener-extension-provider-aws (Go): affected all versions; fixed in 1.64.0
- github.com/gardener/gardener-extension-provider-aws (Go): affected all versions; fixed in 1.64.0
- github.com/gardener/gardener-extension-provider-aws (Go): affected all versions; fixed in 1.64.0
- github.com/gardener/gardener-extension-provider-azure (Go): affected all versions; fixed in 1.55.0
- github.com/gardener/gardener-extension-provider-azure (Go): affected all versions; fixed in 1.55.0
- github.com/gardener/gardener-extension-provider-azure (Go): affected all versions; fixed in 1.55.0
- github.com/gardener/gardener-extension-provider-gcp (Go): affected all versions; fixed in 1.46.0
- github.com/gardener/gardener-extension-provider-gcp (Go): affected all versions; fixed in 1.46.0
- github.com/gardener/gardener-extension-provider-gcp (Go): affected all versions; fixed in 1.46.0
- github.com/gardener/gardener-extension-provider-openstack (Go): affected all versions; fixed in 1.49.0
- github.com/gardener/gardener-extension-provider-openstack (Go): affected all versions; fixed in 1.49.0
- github.com/gardener/gardener-extension-provider-openstack (Go): affected all versions; fixed in 1.49.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59823/ (Markdown: https://insights.sbomify.com/CVE-2025-59823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59823
- OSV: https://osv.dev/vulnerability/CVE-2025-59823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59823/
Summaries are generated and may contain mistakes; the official description above is the record.
