CVE-2025-59828 Claude Code Vulnerable to Arbitrary Code Execution via Plugin Autoloading with Specific Yarn Versions

High 7.7 Published Updated

Attackers can execute arbitrary code by exploiting Yarn plugin autoloading to bypass directory trust checks in Claude Code.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-59828?

CVE-2025-59828 is a high-severity code injection vulnerability in anthropics claude-code, published on 24 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.

Weakness: CWE-862, CWE-829

Which versions are affected by CVE-2025-59828?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.

PackageAffectedFixed in
@anthropic-ai/claude-code npmAll versions1.0.39
@anthropic-ai/claude-code npmAll versions1.0.39

Products include Anthropic Claude Code.

How do I fix CVE-2025-59828?

Upgrade @anthropic-ai/claude-code to 1.0.39 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-59828 being exploited?

There is no known exploitation of CVE-2025-59828 in the wild and no public exploit code.

Sources

Also known as GHSA-2jjv-qf24-vfm4.

Is CVE-2025-59828 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free