{"answers":{"affected":"2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59828 in the wild and no public exploit code.","fix":"Upgrade @anthropic-ai/claude-code to 1.0.39 or later.","what":"CVE-2025-59828 is a high-severity code injection vulnerability in anthropics claude-code, published on 24 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59828 and fix it if it is affected.\n\nWhat it is: CVE-2025-59828 is a high-severity code injection vulnerability in anthropics claude-code, published on 24 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59828 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.39\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.39\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59828/ (Markdown: https://insights.sbomify.com/CVE-2025-59828/index.md)","id":"CVE-2025-59828","markdown":"https://insights.sbomify.com/CVE-2025-59828/index.md","name":"CVE-2025-59828","record":{"aliases":["GHSA-2jjv-qf24-vfm4"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Claude Code CLI","requires_auth":"none","summary":"Attackers can execute arbitrary code by exploiting Yarn plugin autoloading to bypass directory trust checks in Claude Code.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"claude_code","vendor":"anthropic"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Claude Code Vulnerable to Arbitrary Code Execution via Plugin Autoloading with Specific Yarn Versions","id":"CVE-2025-59828","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Claude Code: Permission deny bypass is possible through symlink","id":"CVE-2025-59829"},"packages":[{"ecosystem":"npm","fixed":["1.0.39"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":null,"source":"GHSA-2jjv-qf24-vfm4"},{"ecosystem":"npm","fixed":["1.0.39"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":"pkg:npm/%40anthropic-ai/claude-code","source":"GHSA-2jjv-qf24-vfm4"}],"prev":{"headline":"FlagForgeCTF is Missing Authorization in main-v2","id":"CVE-2025-59827"},"products":["claude-code"],"published":"2025-09-24","related":[{"cvss_score":8.7,"headline":"Claude Code Command Validation Bypass Allows Arbitrary Code Execution","id":"CVE-2025-66032","kev_date_added":null,"published":"2025-12-03"},{"cvss_score":8.7,"headline":"@anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes","id":"CVE-2025-64755","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":8.7,"headline":"Claude Code's startup trust dialog could lead to Command Execution attack","id":"CVE-2025-59536","kev_date_added":null,"published":"2025-10-03"},{"cvss_score":8.7,"headline":"Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution","id":"CVE-2025-58764","kev_date_added":null,"published":"2025-09-10"},{"cvss_score":8.7,"headline":"Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email","id":"CVE-2025-59041","kev_date_added":null,"published":"2025-09-10"},{"cvss_score":8.7,"headline":"Claude Code echo command allowed bypass of user approval prompt for command execution","id":"CVE-2025-54795","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":7.7,"headline":"Claude Code: Sandbox Escape via Git Worktree Path Confusion Allows Unsandboxed Code Execution","id":"CVE-2026-55607","kev_date_added":null,"published":"2026-06-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-24","vendors":["anthropics"]},"summary":"Attackers can execute arbitrary code by exploiting Yarn plugin autoloading to bypass directory trust checks in Claude Code.","url":"https://insights.sbomify.com/CVE-2025-59828/"}