{"answers":{"affected":"2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59829 in the wild and no public exploit code.","fix":"Upgrade @anthropic-ai/claude-code to 1.0.120 or later.","what":"CVE-2025-59829 is a low-severity path traversal vulnerability in anthropics claude-code, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59829 and fix it if it is affected.\n\nWhat it is: CVE-2025-59829 is a low-severity path traversal vulnerability in anthropics claude-code, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59829 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.120\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.120\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59829/ (Markdown: https://insights.sbomify.com/CVE-2025-59829/index.md)","id":"CVE-2025-59829","markdown":"https://insights.sbomify.com/CVE-2025-59829/index.md","name":"CVE-2025-59829","record":{"aliases":["GHSA-66m2-gx93-v996"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI coding assistant","requires_auth":"none","summary":"Attackers can bypass file access restrictions in Claude Code by using symlinks to read denied files, requiring an upgrade to the latest version.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"claude_code","vendor":"anthropic"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-61","name":"UNIX Symbolic Link (Symlink) Following"}],"description":"Claude Code is an agentic coding tool. Versions below 1.0.120 failed to account for symlinks when checking permission deny rules. If a user explicitly denied Claude Code access to a file and Claude Code had access to a symlink pointing to that file, it was possible for Claude Code to access the file. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. This issue is fixed in version 1.0.120.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Claude Code: Permission deny bypass is possible through symlink","id":"CVE-2025-59829","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Rack QueryParser has an unsafe default allowing params_limit bypass via semicolon-separated parameters","id":"CVE-2025-59830"},"packages":[{"ecosystem":"npm","fixed":["1.0.120"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":null,"source":"GHSA-66m2-gx93-v996"},{"ecosystem":"npm","fixed":["1.0.120"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":"pkg:npm/%40anthropic-ai/claude-code","source":"GHSA-66m2-gx93-v996"}],"prev":{"headline":"Claude Code Vulnerable to Arbitrary Code Execution via Plugin Autoloading with Specific Yarn Versions","id":"CVE-2025-59828"},"products":["claude-code"],"published":"2025-10-03","related":[{"cvss_score":8.7,"headline":"Claude Code Command Validation Bypass Allows Arbitrary Code Execution","id":"CVE-2025-66032","kev_date_added":null,"published":"2025-12-03"},{"cvss_score":8.7,"headline":"@anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes","id":"CVE-2025-64755","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":8.7,"headline":"Claude Code's startup trust dialog could lead to Command Execution attack","id":"CVE-2025-59536","kev_date_added":null,"published":"2025-10-03"},{"cvss_score":8.7,"headline":"Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution","id":"CVE-2025-58764","kev_date_added":null,"published":"2025-09-10"},{"cvss_score":8.7,"headline":"Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email","id":"CVE-2025-59041","kev_date_added":null,"published":"2025-09-10"},{"cvss_score":8.7,"headline":"Claude Code echo command allowed bypass of user approval prompt for command execution","id":"CVE-2025-54795","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":7.7,"headline":"Claude Code: Sandbox Escape via Git Worktree Path Confusion Allows Unsandboxed Code Execution","id":"CVE-2026-55607","kev_date_added":null,"published":"2026-06-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-03","vendors":["anthropics"]},"summary":"Attackers can bypass file access restrictions in Claude Code by using symlinks to read denied files, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-59829/"}