# CVE-2025-59829: Claude Code: Permission deny bypass is possible through symlink

> Attackers can bypass file access restrictions in Claude Code by using symlinks to read denied files, requiring an upgrade to the latest version.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** GHSA-66m2-gx93-v996

## What is CVE-2025-59829?

CVE-2025-59829 is a low-severity path traversal vulnerability in anthropics claude-code, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Versions below 1.0.120 failed to account for symlinks when checking permission deny rules. If a user explicitly denied Claude Code access to a file and Claude Code had access to a symlink pointing to that file, it was possible for Claude Code to access the file. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. This issue is fixed in version 1.0.120.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2025-59829?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 1.0.120 |
| `@anthropic-ai/claude-code` | npm | All versions | 1.0.120 |

Products: Anthropic Claude Code.

## How do I fix CVE-2025-59829?

Upgrade @anthropic-ai/claude-code to 1.0.120 or later.

## Is CVE-2025-59829 being exploited?

There is no known exploitation of CVE-2025-59829 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59829 and fix it if it is affected.

What it is: CVE-2025-59829 is a low-severity path traversal vulnerability in anthropics claude-code, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59829 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.120
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.120

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59829/ (Markdown: https://insights.sbomify.com/CVE-2025-59829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59829
- OSV: https://osv.dev/vulnerability/CVE-2025-59829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59829/
Summaries are generated and may contain mistakes; the official description above is the record.
