# CVE-2025-59830: Rack QueryParser has an unsafe default allowing params_limit bypass via semicolon-separated parameters

> Attackers can bypass parameter limits in Rack QueryParser using semicolon separators, causing resource exhaustion and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2025
- **Updated:** 25 Sep 2025
- **Also known as:** DEBIAN-CVE-2025-59830, GHSA-625h-95r8-8xpm, MINI-g4w3-gvr3-h232, MINI-h6mq-42gm-4qhr, MINI-jcj8-ph3h-wxv8, MINI-p8fx-9m2q-qhr9, MINI-wr88-5f8m-8fhq, UBUNTU-CVE-2025-59830, USN-7784-1, openSUSE-SU-2025:15587-1

## What is CVE-2025-59830?

CVE-2025-59830 is a high-severity denial of service vulnerability in rack, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-59830?

2 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.18 |
| `rack` | RubyGems | All versions | 2.2.18 |
| `rubygem-rack-2.2` | openSUSE:Tumbleweed | All versions | 2.2.18-1.1 |

Products: Rack Rack.

## How do I fix CVE-2025-59830?

Upgrade rack to 2.2.18 or later.

## Is CVE-2025-59830 being exploited?

There is no known exploitation of CVE-2025-59830 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59830 and fix it if it is affected.

What it is: CVE-2025-59830 is a high-severity denial of service vulnerability in rack, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59830 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.18
- rack (RubyGems): affected all versions; fixed in 2.2.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59830/ (Markdown: https://insights.sbomify.com/CVE-2025-59830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59830
- OSV: https://osv.dev/vulnerability/CVE-2025-59830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59830/
Summaries are generated and may contain mistakes; the official description above is the record.
