CVE-2025-59837 astro allows bypass of image proxy domain validation leading to SSRF and potential XSS

High 7.2 Published Updated

Attackers can bypass image proxy validation to perform SSRF and potentially XSS, requiring an upgrade to the Astro framework.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59837?

CVE-2025-59837 is a high-severity server-side request forgery vulnerability in withastro astro, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Astro is a web framework that includes an image proxy. In versions 5.13.4 and later before 5.13.10, the image proxy domain validation can be bypassed by using backslashes in the href parameter, allowing server-side requests to arbitrary URLs. This can lead to server-side request forgery (SSRF) and potentially cross-site scripting (XSS). This vulnerability exists due to an incomplete fix for CVE-2025-58179. Fixed in 5.13.10.

Weakness: CWE-918, CWE-79

Which versions are affected by CVE-2025-59837?

2 open source packages ship an affected version, including astro. It affects 1 product.

PackageAffectedFixed in
astro npmFrom 5.13.45.13.10
astro npmFrom 5.13.45.13.10

Products include Astro Astro.

How do I fix CVE-2025-59837?

Upgrade astro to 5.13.10 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-59837 being exploited?

There is no known exploitation of CVE-2025-59837 in the wild and no public exploit code.

Sources

Also known as GHSA-qcpr-679q-rhm2.

Is CVE-2025-59837 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free