# CVE-2025-59837: astro allows bypass of image proxy domain validation leading to SSRF and potential XSS

> Attackers can bypass image proxy validation to perform SSRF and potentially XSS, requiring an upgrade to the Astro framework.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-qcpr-679q-rhm2

## What is CVE-2025-59837?

CVE-2025-59837 is a high-severity server-side request forgery vulnerability in withastro astro, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Astro is a web framework that includes an image proxy. In versions 5.13.4 and later before 5.13.10, the image proxy domain validation can be bypassed by using backslashes in the href parameter, allowing server-side requests to arbitrary URLs. This can lead to server-side request forgery (SSRF) and potentially cross-site scripting (XSS). This vulnerability exists due to an incomplete fix for CVE-2025-58179. Fixed in 5.13.10.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59837?

2 open source packages ship an affected version, including astro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astro` | npm | From 5.13.4 | 5.13.10 |
| `astro` | npm | From 5.13.4 | 5.13.10 |

Products: Astro Astro.

## How do I fix CVE-2025-59837?

Upgrade astro to 5.13.10 or later.

## Is CVE-2025-59837 being exploited?

There is no known exploitation of CVE-2025-59837 in the wild and no public exploit code.

## Other vulnerabilities in withastro astro

- [CVE-2024-56159](https://insights.sbomify.com/CVE-2024-56159/): Server source code is exposed to the public if sourcemaps are enabled (high 7.8)
- [CVE-2026-54299](https://insights.sbomify.com/CVE-2026-54299/): Astro: Host header SSRF in prerendered error page fetch (high 7.5)
- [CVE-2026-50146](https://insights.sbomify.com/CVE-2026-50146/): Astro: Reflected XSS via unescaped slot name (high 7.1)
- [CVE-2025-64764](https://insights.sbomify.com/CVE-2025-64764/): Astro is vulnerable to Reflected XSS via the server islands feature (high 7.1)
- [CVE-2025-64765](https://insights.sbomify.com/CVE-2025-64765/): Astro middleware authentication checks based on url.pathname can be bypassed via url encoded values (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59837 and fix it if it is affected.

What it is: CVE-2025-59837 is a high-severity server-side request forgery vulnerability in withastro astro, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59837 in the wild and no public exploit code.

Affected packages and fixed versions:
- astro (npm): affected from 5.13.4; fixed in 5.13.10
- astro (npm): affected from 5.13.4; fixed in 5.13.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59837/ (Markdown: https://insights.sbomify.com/CVE-2025-59837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59837
- OSV: https://osv.dev/vulnerability/CVE-2025-59837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59837/
Summaries are generated and may contain mistakes; the official description above is the record.
