CVE-2025-59838 Monkeytype Vulnerable to Self-XSS on loading saved custom text

Low 2.4 Published Updated

An attacker can execute arbitrary scripts in a victim's browser by tricking them into loading a malicious saved custom text in Monkeytype.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-59838?

CVE-2025-59838 is a low-severity cross-site scripting vulnerability in monkeytypegame monkeytype, published on 25 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Monkeytype is a minimalistic and customizable typing test. In versions 25.36.0 and prior, improper handling of user input when loading a saved custom text results in XSS. This issue has been fixed in version 25.44.0.

Weakness: CWE-79

Which versions are affected by CVE-2025-59838?

It affects 1 product.

Products include Monkeytype Monkeytype.

How do I fix CVE-2025-59838?

No fix has been published for CVE-2025-59838 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-59838 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59838 exists.

Sources

Also known as GHSA-j4xx-fww5-774w.

Is CVE-2025-59838 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free