# CVE-2025-59838: Monkeytype Vulnerable to Self-XSS on loading saved custom text

> An attacker can execute arbitrary scripts in a victim's browser by tricking them into loading a malicious saved custom text in Monkeytype.

- **Severity:** Low 2.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Sep 2025
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-j4xx-fww5-774w

## What is CVE-2025-59838?

CVE-2025-59838 is a low-severity cross-site scripting vulnerability in monkeytypegame monkeytype, published on 25 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Monkeytype is a minimalistic and customizable typing test. In versions 25.36.0 and prior, improper handling of user input when loading a saved custom text results in XSS. This issue has been fixed in version 25.44.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59838?

It affects 1 product.


Products: Monkeytype Monkeytype.

## How do I fix CVE-2025-59838?

No fix has been published for CVE-2025-59838 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59838 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59838 exists.

## Other vulnerabilities in monkeytypegame monkeytype

- [CVE-2024-41127](https://insights.sbomify.com/CVE-2024-41127/): Code injection in monkeytype (high 8.4)
- [CVE-2025-66563](https://insights.sbomify.com/CVE-2025-66563/): Monkeytype vulnerable to stored XSS in approve quotes page (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59838 and fix it if it is affected.

What it is: CVE-2025-59838 is a low-severity cross-site scripting vulnerability in monkeytypegame monkeytype, published on 25 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59838 exists.

Affected product: monkeytypegame monkeytype. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59838/ (Markdown: https://insights.sbomify.com/CVE-2025-59838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59838
- OSV: https://osv.dev/vulnerability/CVE-2025-59838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59838/
Summaries are generated and may contain mistakes; the official description above is the record.
