# CVE-2025-59842: JupyterLab LaTeX typesetter links did not enforce `noopener` attribute

> JupyterLab LaTeX links lacked noopener, enabling reverse tabnabbing in specific third-party extension scenarios.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2025
- **Updated:** 26 Sep 2025
- **Also known as:** BIT-jupyterlab-2025-59842, DEBIAN-CVE-2025-59842, GHSA-vvfj-2jqx-52jm, PYSEC-2026-1482, UBUNTU-CVE-2025-59842, openSUSE-SU-2025:15591-1

## What is CVE-2025-59842?

CVE-2025-59842 is a low-severity vulnerability in jupyterlab, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. Prior to version 4.4.8, links generated with LaTeX typesetters in Markdown files and Markdown cells in JupyterLab and Jupyter Notebook did not include the noopener attribute. This is deemed to have no impact on the default installations. Theoretically users of third-party LaTeX-rendering extensions could find themselves vulnerable to reverse tabnabbing attacks if links generated by those extensions included target=_blank (no such extensions are known at time of writing) and they were to click on a link generated in LaTeX (typically visibly different from other links). This issue has been patched in version 4.4.8.

Weakness: CWE-1022 (Use of Web Link to Untrusted Target with window.opener Access)

## Which versions are affected by CVE-2025-59842?

4 open source packages ship an affected version, including jupyterlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab` | Bitnami | All versions | 4.4.8 |
| `jupyterlab` | PyPI | All versions | 4.4.8 |
| `jupyterlab` | PyPI | All versions | 4.4.8 |
| `jupyterlab` | PyPI | All versions | 4.4.8 |
| `python-jupyterlab` | openSUSE:Tumbleweed | All versions | 4.4.9-1.1 |

Products: Jupyter Jupyterlab.

## How do I fix CVE-2025-59842?

Upgrade jupyterlab to 4.4.8 or later.

## Is CVE-2025-59842 being exploited?

There is no known exploitation of CVE-2025-59842 in the wild and no public exploit code.

## Other vulnerabilities in jupyterlab

- [CVE-2024-39700](https://insights.sbomify.com/CVE-2024-39700/): Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action (critical 10.0)
- [CVE-2026-42266](https://insights.sbomify.com/CVE-2026-42266/): JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request (high 8.8)
- [CVE-2026-42557](https://insights.sbomify.com/CVE-2026-42557/): jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content (high 8.6)
- [CVE-2024-43805](https://insights.sbomify.com/CVE-2024-43805/): HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering (high 7.6)
- [CVE-2021-32797](https://insights.sbomify.com/CVE-2021-32797/): JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59842 and fix it if it is affected.

What it is: CVE-2025-59842 is a low-severity vulnerability in jupyterlab, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59842 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterlab (Bitnami): affected all versions; fixed in 4.4.8
- jupyterlab (PyPI): affected all versions; fixed in 4.4.8
- jupyterlab (PyPI): affected all versions; fixed in 4.4.8
- jupyterlab (PyPI): affected all versions; fixed in 4.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59842/ (Markdown: https://insights.sbomify.com/CVE-2025-59842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59842
- OSV: https://osv.dev/vulnerability/CVE-2025-59842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59842/
Summaries are generated and may contain mistakes; the official description above is the record.
