{"answers":{"affected":"4 open source packages ship an affected version, including @apollo/explorer and @apollo/sandbox.","exploited":"There is no known exploitation of CVE-2025-59845 in the wild and no public exploit code.","fix":"Upgrade @apollo/explorer to 3.7.3 or later.","what":"CVE-2025-59845 is a high-severity vulnerability in apollographql embeddable-explorer, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59845 and fix it if it is affected.\n\nWhat it is: CVE-2025-59845 is a high-severity vulnerability in apollographql embeddable-explorer, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59845 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @apollo/explorer (npm): affected all versions; fixed in 3.7.3\n- @apollo/explorer (npm): affected all versions; fixed in 3.7.3\n- @apollo/sandbox (npm): affected all versions; fixed in 2.7.2\n- @apollo/sandbox (npm): affected all versions; fixed in 2.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59845/ (Markdown: https://insights.sbomify.com/CVE-2025-59845/index.md)","id":"CVE-2025-59845","markdown":"https://insights.sbomify.com/CVE-2025-59845/index.md","name":"CVE-2025-59845","record":{"aliases":["GHSA-w87v-7w53-wwxv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apollo GraphQL Explorer","requires_auth":"none","summary":"Attackers can forge messages to execute arbitrary GraphQL queries or mutations on behalf of authenticated users via missing origin validation.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-346","name":"Origin Validation Error"}],"description":"Apollo Studio Embeddable Explorer \u0026 Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass","id":"CVE-2025-59845","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"HCL BigFix Remote Control is vulnerable to an insecure CSP configuration","id":"CVE-2025-59849"},"packages":[{"ecosystem":"npm","fixed":["3.7.3"],"introduced":["0"],"last_affected":[],"package":"@apollo/explorer","purl":null,"source":"GHSA-w87v-7w53-wwxv"},{"ecosystem":"npm","fixed":["3.7.3"],"introduced":["0"],"last_affected":[],"package":"@apollo/explorer","purl":"pkg:npm/%40apollo/explorer","source":"GHSA-w87v-7w53-wwxv"},{"ecosystem":"npm","fixed":["2.7.2"],"introduced":["0"],"last_affected":[],"package":"@apollo/sandbox","purl":null,"source":"GHSA-w87v-7w53-wwxv"},{"ecosystem":"npm","fixed":["2.7.2"],"introduced":["0"],"last_affected":[],"package":"@apollo/sandbox","purl":"pkg:npm/%40apollo/sandbox","source":"GHSA-w87v-7w53-wwxv"}],"prev":{"headline":"Argument injection vulnerability in SonarQube Scan Action","id":"CVE-2025-59844"},"products":["embeddable-explorer"],"published":"2025-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-29","vendors":["apollographql"]},"summary":"Attackers can forge messages to execute arbitrary GraphQL queries or mutations on behalf of authenticated users via missing origin validation.","url":"https://insights.sbomify.com/CVE-2025-59845/"}