# CVE-2025-59845: Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass

> Attackers can forge messages to execute arbitrary GraphQL queries or mutations on behalf of authenticated users via missing origin validation.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2025
- **Updated:** 29 Sep 2025
- **Also known as:** GHSA-w87v-7w53-wwxv

## What is CVE-2025-59845?

CVE-2025-59845 is a high-severity vulnerability in apollographql embeddable-explorer, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2025-59845?

4 open source packages ship an affected version, including @apollo/explorer and @apollo/sandbox.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apollo/explorer` | npm | All versions | 3.7.3 |
| `@apollo/explorer` | npm | All versions | 3.7.3 |
| `@apollo/sandbox` | npm | All versions | 2.7.2 |
| `@apollo/sandbox` | npm | All versions | 2.7.2 |

## How do I fix CVE-2025-59845?

Upgrade @apollo/explorer to 3.7.3 or later.

## Is CVE-2025-59845 being exploited?

There is no known exploitation of CVE-2025-59845 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59845 and fix it if it is affected.

What it is: CVE-2025-59845 is a high-severity vulnerability in apollographql embeddable-explorer, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59845 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apollo/explorer (npm): affected all versions; fixed in 3.7.3
- @apollo/explorer (npm): affected all versions; fixed in 3.7.3
- @apollo/sandbox (npm): affected all versions; fixed in 2.7.2
- @apollo/sandbox (npm): affected all versions; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59845/ (Markdown: https://insights.sbomify.com/CVE-2025-59845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59845
- OSV: https://osv.dev/vulnerability/CVE-2025-59845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59845/
Summaries are generated and may contain mistakes; the official description above is the record.
